We develop 99% of our websites using Joomla!, so their latest release is an extremely important one for us. Please take the time to read the article below:

https://www.joomla.org/announcements/release-news/5634-joomla-3-4-5-released.html

It was updated due to security issues and the threat of being hacked for websites using any Joomla! version below 3.4.8 (contact us if you are unsure).

Joomla! were extremely quick to release this update having been made aware of the threat and the vulnerabilities that it possessed.

If you are a client of ours and are not on a monthly management programme, the chances are your website will need to be updated. We can do this for a flat, one-off fee and it will ensure that your site is once again secure. For this one off fee, we will also include a backup of your website and a check to update any plug-ins that are currently installed.

If you would like to know more, please contact us.

We must stress that this is an extremely important update. The more time that lapses without you updating your site, the higher the risk of you getting hacked becomes.